Possible delay in HUF payouts from the 20th of April
Incident Report for Paylike
Resolved
We are seeing reports from our affected customers stating that the transfers from the 20th of April have arrived to their bank accounts. We are not seeing more claims indicating that anyone else is still missing their funds from the mentioned date. Therefore we have closed down this incident while we remain in contact with our banking partner to ensure future transfers arrive within the expected schedule of 1-4 working days.

If you have any comments or questions, feel free to reach out via hello@paylike.io.
Posted May 04, 2022 - 14:43 UTC
Monitoring
Today, on the 27th of April, we started receiving confirmations from our customers that the delayed transfers have arrived to their bank accounts.

We remain in contact with our banking partner and keep monitoring the situation to ensure all affected transfers arrive as soon as possible.

We expect future transfers, including today's payouts, to arrive according to the usual 1-4 working days timeframe.
Posted Apr 27, 2022 - 10:41 UTC
Investigating
We have received several reports from our customers experiencing a delay in HUF payouts transferred on the 20th of April.

While the usual processing time is 1-2 working days, bank transfers can take up to 4 working days to be visible on the recipient's bank account. We are in contact with our banking partner to ensure the funds arrive within the 4-day timeframe or to receive back the funds and reroute them via another banking partner.

Currently we were informed that only HUF transfer are affected by the incident and we have not received reports on delays regarding transfers in other currencies.

We are currently monitoring the situation and are treating this incident with the utmost urgency.
Posted Apr 25, 2022 - 17:17 UTC