Delayed HUF payouts from 23rd of February
Incident Report for Paylike
Resolved
On the 3rd of March the majority of the affected customers have confirmed that their delayed settlement from last Wednesday have arrived to their bank accounts. We have not received any inquires during this day regarding the late settlement, therefore we expect the issue to be fully resolved soon for all affected customers.

We will remain in contact with Citibank to ensure their transfer schedule is back to normal.

Due to this incident, the payouts in the HUF currency from the 2nd of March have been transferred via an alternative banking partner to ensure the funds arrive within the expected 1-4 days timeframe.
Posted Mar 03, 2022 - 16:48 UTC
Update
We have today the 2nd of March received the first reports of HUF payouts being received indicating that the issue has been resolved at least for some banks in Hungary. We will continue to monitor the situation and update here accordingly.
Posted Mar 02, 2022 - 15:09 UTC
Identified
We are unfortunately experiencing a delay on HUF payouts from February 23rd with our local banking provider.

On Monday February 28th we launched an investigation into reports of missing payouts and narrowed the issue down to HUF payouts from February 23rd going through Citibank, one of our local banking partners.

We contacted the partner bank and received response on Tuesday March 1st that they were investigating and would return as soon as possible.

Today, Wednesday March 2nd, we unfortunately do not yet have any estimate from Citibank on the issue. We are expecting their communication anytime and will update here as soon as new information is available.

We are truly sorry for the inconvenience this is causing and are exploring workarounds. Unfortunately, as the payments are currently in an "unknown" state, they are not easily rerouted.

About the weekly payouts March 2nd, we will be awaiting Citibank the rest of they day. In case we do not have affirmative confirmation that the issue is resolved, or will not affect future payments, by end of day, we will route payments through alternative banking partners to avoid escalating the issue.
We expect this to cause 1-2 days delay on today's payouts.
Posted Mar 02, 2022 - 12:45 UTC