Duplicate payments
Incident Report for Paylike
Resolved
Visa has confirmed processing of all reversals. Thus all card customers affected should now see a reversal of the duplicate charge on the same date.

We once again apologize for the inconvenience and will follow up on our partner's post-mortem.
Posted Oct 13, 2021 - 13:13 UTC
Update
Our partner has confirmed processing of all reversals with Mastercard. Depending on the speed of import with each issuer, the reversals should be visible on account statements tomorrow on the date of the original charge. Reversals for Visa are likewise expected to be processed today, but final confirmation is yet to be provided.
Posted Oct 12, 2021 - 13:06 UTC
Identified
A financial partner of ours have unfortunately, by mistake, processed some transactions in the time between 2021-10-06 19:00:00 UTC and 2021-10-07 18:59:59 UTC twice.

They will all be reversed as soon as possible.

Payment card customers may therefore see their account charged twice. This will be corrected with a reversal on the same date of the duplicate charge as soon as possible.

We sincerely apologies for the inconvenience and ask for your patience with our partner.

An update will be posted when all reversals have been confirmed.
Posted Oct 11, 2021 - 08:33 UTC
This incident affected: Transaction gateway (gateway.paylike.io), API (api.paylike.io), and Dashboard (app.paylike.io).